[CLUG-tech] IBM SAN multipath

Adrian Snyman adrians at supply-chain.co.za
Fri Dec 7 15:06:36 SAST 2007


Adrian Moisey wrote:
> Hi
> 
> I've got an IBM SAN plugged into 2 single port HBA QLogic cards, but
> I'm failing at getting multipath going.  I haven't much experience in
> this, so I'm not sure what info I should giev for debugging.  But here
> does:
> 
> $ multipath -d -ll
> sda: checker msg is "readsector0 checker reports path is down"
> 3600a0b8000349b770000029147575846dm-0 IBM,1726-4xx  FAStT
> [size=250G][features=0][hwhandler=0]
> \_ round-robin 0 [prio=0][enabled]
>  \_ 0:0:0:0 sda 8:0   [active][faulty]
> \_ round-robin 0 [prio=1][enabled]
>  \_ 1:0:0:0 sdb 8:16  [active][ready]
> $ scsiinfo -l
> /dev/sda /dev/sdb /dev/sdc /dev/sdd /dev/scd0
> 
> 
> sda and sdb are both a single LUN on the SAN, sdc and sdd are local disks.
> 
> $ dmesg | grep sda
> [  114.435441] sd 0:0:0:0: [sda] 524288000 512-byte hardware sectors (268435 MB)
> [  114.435598] sd 0:0:0:0: [sda] Write Protect is off
> [  114.435601] sd 0:0:0:0: [sda] Mode Sense: 77 00 10 08
> [  114.435861] sd 0:0:0:0: [sda] Write cache: enabled, read cache:
> enabled, supports DPO and FUA
> [  114.436657] sd 0:0:0:0: [sda] 524288000 512-byte hardware sectors (268435 MB)
> [  114.436801] sd 0:0:0:0: [sda] Write Protect is off
> [  114.436805] sd 0:0:0:0: [sda] Mode Sense: 77 00 10 08
> [  114.437082] sd 0:0:0:0: [sda] Write cache: enabled, read cache:
> enabled, supports DPO and FUA
> [  114.437086]  sda:floppy0: no floppy controllers found
> [  114.940863] end_request: I/O error, dev sda, sector 0
> [  114.940868] Buffer I/O error on device sda, logical block 0
> [  115.473329] end_request: I/O error, dev sda, sector 0
> [  115.473332] Buffer I/O error on device sda, logical block 0
> [  115.989200] end_request: I/O error, dev sda, sector 0
> [  115.989205] Buffer I/O error on device sda, logical block 0
> [  116.505048] end_request: I/O error, dev sda, sector 0
> [  116.505053] Buffer I/O error on device sda, logical block 0
> ...
> [  127.005515] end_request: I/O error, dev sda, sector 524287992
> [  127.520987] end_request: I/O error, dev sda, sector 524287992
> [  128.036850] end_request: I/O error, dev sda, sector 524287992
> [  128.569325] end_request: I/O error, dev sda, sector 524287992
> [  129.101832] end_request: I/O error, dev sda, sector 524287992
> [  129.615070] end_request: I/O error, dev sda, sector 524287992
> [  130.133533] end_request: I/O error, dev sda, sector 524287992
> [  130.133539] Buffer I/O error on device sda, logical block 65535999
> 
> $ lspci | grep QLogic
> 0b:02.0 Fibre Channel: QLogic Corp. ISP2422-based 4Gb Fibre Channel to
> PCI-X HBA (rev 02)
> 0d:00.0 Fibre Channel: QLogic Corp. ISP2432-based 4Gb Fibre Channel to
> PCI Express HBA (rev 03)
> 
> Any ideas?

What config is written in your modules.conf ??

we got:

options qla2200  ql2xmaxqdepth=32 qlport_down_retry=30 
qlogin_retry_count=16 ql2xfailover=1 ql2xlbType=1 ql2xexcludemodel=0x0 
ql2xautorestore=0x80

options qla2300  ql2xmaxqdepth=32 qlport_down_retry=30 
qlogin_retry_count=16 ql2xfailover=1 ql2xlbType=1 ql2xexcludemodel=0x0 
ql2xautorestore=0x80

I am sure you can tweak them ... depending on the card of course ...

-- 
Regards,
Adrian Snyman
Linux Systems Administrator
Tel: (011) 230-6040
Fax: (086) 673-7373
==================
Please read our Email Disclaimer :
http://www.supply-chain.co.za/disclaimer.html


More information about the clug-tech mailing list