[CLUG-tech] 3G Huwaei 220 on debian

marius marius at sanbi.ac.za
Tue Dec 4 09:01:12 SAST 2007


Hans van der Merwe wrote:
> On Mon, 2007-12-03 at 14:55 +0200, marius wrote:
>   
>> Hi all,
>> I've previously got some info on getting this modem to work on debian 
>> off the web.
>>
>> I tried the python package - no-go.
>>
>> I tried other advice that said that no additional packages are required 
>> for debian, and that the following steps are all that's needed:
>>
>> 0. plug the modem into usb, wait
>>
>> 1. rmmod usb_storage
>>
>> 2. lsusb
>>     -this is to get vendor and prod-id's
>>
>> 3. modprobe usbserial vendor=0xnum-from-above product=0xnum-from-above
>>
>> 4. unplug, wait, plug, wait
>>
>> 5. setup wvdial (can't remember all the settings)
>>     (I did all the settings under [Dialer Defaults])
>>     - Username = ?( I use vodafone)
>>     - Password = ?( I use vodafone)
>>     - phone number -- *99***1# (if I remember it correctly)
>>
>> 6. sudo wvdial
>>
>>     - finds modem
>>     - does handshaking, dials, etc
>>     - then says: CONNECTED
>>     - it then waits a while and the line is dropped (i think from the 
>> vodacom side) and the it goes on trying to reconnect unsuccesfully
>>
>> Question:
>> How do I get this @#$*& thing to work?
>>
>> TIA
>>     
>
> Well, congrats on getting that far - I have to keep on re-plugging the
> device about 10 times before it provides a stable ttyUSB0 device point.
> Maybe you should post your wvdial config file.  If you get CONNECTED,
> then Im sure there is only some minor issue in the config.
>
> Hans
>  
>
>
> E-mail Disclaimer
> http://www.sunspace.co.za/emaildisclaimer.htm
>
>   
(I'm setting up the 3G stuff at home & sending these emails from work)

anyway... the quote below gives all that I have done, but with a few new 
things in the wvdial.conf that I still need too try - but I think this 
will work

<QUOTE>
Go to System Settings / Network Settings and disable Ethernet and 
Wireless as these interfere greatly with the Huawei. <<<<<comment by 
marius: I did not do this and very much doubt if it is true, but if all 
else fails will try this as a last resort>>>>>

(I read in a few places that the long cable doesn't work but this is NOT 
my experience... I use the long one with an extension of two metres and 
my connection then, (only then) has a strong and stable signal)

Open a terminal as root

rmmod usb-storage
modprobe usbserial vendor=0x12d1 product=0x1003

remove the Huawei E220 for a few moments

wait a few seconds, maybe 10-20, and re-insert

optionally, you can enter:
ls -la /dev/ttyU*
and you will probably
find USB0 USB1 and USB2 ..
if not, wait a few more moments and try again...
then...

wvdial hsdpa

You should be connected!

Here is my wvdial file:

[[[marius comments:
If you create the [... hsdpa]-section you call wvdial like so:
sudo wvdial hsdpa

I stuffed mine all into the defaults section since its the only time I 
use wvdial
I still need to try the conf below, but what is diff/new to me is the Init5
]]]

/etc/wvdial.conf

[Dialer hsdpa]
Phone = *99***1#
Username = vodafone
Password = vodafone
Stupid Mode = 1
Dial Command = ATDT
Modem = /dev/ttyUSB0
Baud = 460800
Init2 = ATZ
Init3 = ATE0V1&D2&C1S0=0+IFC=2,2
ISDN = 0
Modem Type = Analog Modem
Init5 =AT+CGDCONT=1,"IP","ac.vodafone.es";

__________________________________________________ _____


[[[marius comments:
Below is output similar to what I got (up to before the IP & DNS holy 
grails)
]]]

This is what my script looks like when I connect

Password:
root at kp-laptop:/home/daka# rmmod usb-storage
root at kp-laptop:/home/daka# modprobe usbserial vendor=0x12d1 product=0x1003
root at kp-laptop:/home/daka# ls -la /dev/ttyU*
crw-rw---- 1 root dialout 188, 0 2006-12-19 14:33 /dev/ttyUSB0
crw-rw---- 1 root dialout 188, 1 2006-12-19 14:33 /dev/ttyUSB1
crw-rw---- 1 root dialout 188, 2 2006-12-19 14:33 /dev/ttyUSB2
root at kp-laptop:/home/daka# wvdial hsdpa
--> WvDial: Internet dialer version 1.55
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATZ
ATZ
OK
--> Sending: ATE0V1&D2&C1S0=0+IFC=2,2
ATE0V1&D2&C1S0=0+IFC=2,2
OK
--> Sending: AT+CGDCONT=1,"IP","ac.vodafone.es";
OK
--> Modem initialized.
--> Sending: ATDT*99***1#
--> Waiting for carrier.
CONNECT
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Tue Dec 19 14:33:56 2006
--> Pid of pppd: 5550
--> Using interface ppp0
--> local IP address 62.87.24.143
--> remote IP address 10.64.64.64
--> primary DNS address 212.73.32.3
--> secondary DNS address 212.73.32.67
Good Luck... (I hope I haven't made any mistakes in this!!)
</QUOTE>
The above quoted from:  
http://mybroadband.co.za/vb/showthread.php?t=21726&page=47

Just one last thing: the above quoted script was run all within a root 
shell;
that may not be the wisest thing... rather use sudo to allow wvdial to 
update its relevant files... or am i missing the pot?





More information about the clug-tech mailing list