[CLUG-tech] 3G Huwaei 220 on debian

Hans van der Merwe hvdmerwe at sunspace.co.za
Mon Dec 3 15:59:44 SAST 2007


On Mon, 2007-12-03 at 14:55 +0200, marius wrote:
> Hi all,
> I've previously got some info on getting this modem to work on debian 
> off the web.
> 
> I tried the python package - no-go.
> 
> I tried other advice that said that no additional packages are required 
> for debian, and that the following steps are all that's needed:
> 
> 0. plug the modem into usb, wait
> 
> 1. rmmod usb_storage
> 
> 2. lsusb
>     -this is to get vendor and prod-id's
> 
> 3. modprobe usbserial vendor=0xnum-from-above product=0xnum-from-above
> 
> 4. unplug, wait, plug, wait
> 
> 5. setup wvdial (can't remember all the settings)
>     (I did all the settings under [Dialer Defaults])
>     - Username = ?( I use vodafone)
>     - Password = ?( I use vodafone)
>     - phone number -- *99***1# (if I remember it correctly)
> 
> 6. sudo wvdial
> 
>     - finds modem
>     - does handshaking, dials, etc
>     - then says: CONNECTED
>     - it then waits a while and the line is dropped (i think from the 
> vodacom side) and the it goes on trying to reconnect unsuccesfully
> 
> Question:
> How do I get this @#$*& thing to work?
> 
> TIA

Well, congrats on getting that far - I have to keep on re-plugging the
device about 10 times before it provides a stable ttyUSB0 device point.
Maybe you should post your wvdial config file.  If you get CONNECTED,
then Im sure there is only some minor issue in the config.

Hans
 


E-mail Disclaimer
http://www.sunspace.co.za/emaildisclaimer.htm



More information about the clug-tech mailing list