[CLUG-tech] postgres won't start after power failure

Alan McKinnon alan at linuxholdings.co.za
Tue Feb 21 02:17:12 SAST 2006


On Monday, 20 February 2006 15:57, Brendon Gleeson wrote:
> After THE power failure earlier this morning and yesterday, I
> noticed the Postmaster service had not started after booting..
>
> I was hoping to do some devel today but I seriously can't get
> postmaster running? I have had an init script which has worked
> flawlessly through the last years' blackouts but not today.
>
> The debug info has shows nothing, I ran:
> /usr/local/pgsql/bin/postmaster -d 5 -D /usr/local/pgsql/data -i -S
> as user postgres, but NOTHING happens, no debug info or anything?
> just does NOTHING?

NOTHING as in hangs, or NOTHING as in exits? 
What do the logs say?

> Anyone have any ideas? (Slackware 9.1, Postgresql 7.4.9 custom
> compiled)

Probably file corruption. Hopefully it's not the data that got 
corrupted. A quick check would be to store the existing data safely 
away and create a new database. If that works, get out the most 
recent backup

-- 
Alan McKinnon
alan at linuxholdings dot co dot za
+27 82, double three seven, one nine three five


More information about the Clug-tech mailing list