[CLUG-tech] mplayer

Zoltan Szecsei zoltans at geograph.co.za
Thu Feb 9 00:16:05 SAST 2006


gareth wrote:
> hey guys, mplayer got upgraded (to dev-CVS--4.0.3 i think)
> and has since not been working, says this amongst other things
> when i try play any file type:
> 
> ==========================================================================
> open: No such file or directory
> vo_mga: Couldn't open /dev/mga_vid
> open: No such file or directory
> vo_mga: Couldn't open /dev/mga_vid
> tdfxfb: can't open /dev/fb0: No such device
> vo_xvmc: X-Video extension 2.2
> vo_xvmc: X-Video MotionCompensation Extension version 1.0
> ==========================================================================
> Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
> VDec: vo config request - 640 x 480 (preferred colorspace: Mpeg PES)
> Could not find matching colorspace - retrying with -vf scale...
> Opening video filter: [scale]
> The selected video_out device is incompatible with this codec.
> Try adding the scale filter, e.g. -vf spp,scale instead of -vf spp.
> VDecoder init failed :(
> Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
> Selected video codec: [mpeg12] vfm: libmpeg2 (MPEG-1 or 2 (libmpeg2))
> ==========================================================================
> 
> any ideas?
> 
Howzit.
Look at man mplayer and try different options for the -vo parameter.

Presumably you have downloaded ll the win32 codecs?

HTH
Zoltan

-- 


==================================
Geograph (Pty) Ltd
P.O. Box 31255
Tokai 7966
South Africa
Tel:    +27-21-7018492
Fax:	+27-86-6115323
Mobile: +27-83-6004028
==================================



More information about the Clug-tech mailing list